[Openpvrsgx-devgroup] old am3517 version

Jeroen Hofstee jeroen at myspectrum.nl
Mon Dec 30 13:34:42 CET 2019


Hi,

On 12/29/19 9:50 PM, Jeroen Hofstee wrote:
> Hi,
>
> On 12/28/19 1:03 PM, Jeroen Hofstee wrote:
>>
>>
>> I will have a look if there is a sign of live in the DRI/DRM version.
>>
>
> There is it seems, with some adjustmenst and legacy DRM:
>
> [   61.196224] random: crng init done
> [  207.107786] PVR: PVRSRVDrmLoad
> [  207.111297] PVR: PVRCore_Init
> [  207.137901] PVR: EnableSystemClocks: Enabling System Clocks
> [  207.144205] PVR: Setting GPTIMER11 parent to System Clock
> [  207.150193] PVR: GPTIMER11 clock is 13MHz
> [  207.154536] PVR: Setting GPTIMER11 mode to posted (currently is 
> non-posted)
> [  207.167544] omaplfb: Device 0: Framebuffer physical address: 
> 0x8e880000
> [  207.167562] omaplfb: Device 0: Framebuffer virtual address: 0xce880000
> [  207.167574] omaplfb: Device 0: Framebuffer size: 524288
> [  207.167583] omaplfb: Device 0: Framebuffer virtual width: 480
> [  207.167592] omaplfb: Device 0: Framebuffer virtual height: 272
> [  207.167601] omaplfb: Device 0: Framebuffer width: 480
> [  207.167609] omaplfb: Device 0: Framebuffer height: 272
> [  207.167617] omaplfb: Device 0: Framebuffer stride: 1920
> [  207.167627] omaplfb: Device 0: LCM of stride and page size: 61440
> [  207.167635] omaplfb: Device 0: non-DRM framebuffer
> [  207.241599] omaplfb: Device 0: Maximum number of swap chain buffers: 0
> [  207.248525] omaplfb: Device 0: PVR Device ID: 1
> [  207.254172] [drm] Initialized pvrsrvkm 1.9.2188537 20110701 for SGX 
> on minor 1
> [ 1183.853969] PVR: Installing MISR with cookie 3c34baf3
> [ 1183.860657] PVR: Installing device LISR SGX ISR on IRQ 21 with 
> cookie 8b4f6b6c
> [ 1183.868537] PVR: SysFinalise: Version string: SGX revision = 1.2.1
>
> I haven't tested the X server itself though.
> Nor the screen, since I am not near it.
>

When trying to start the X server it is stuck at:

gettimeofday({tv_sec=1577708483, tv_usec=406805}, NULL) = 0
write(0, "[1455485.774] ", 14)          = 14
write(2, "(II) pvr: Driver for PowerVR chi"..., 38(II) pvr: Driver for 
PowerVR chipsets:) = 38
write(0, "(II) pvr: Driver for PowerVR chi"..., 38) = 38
write(2, " ", 1 )                        = 1
write(0, " ", 1)                        = 1
write(2, "PowerVR SGX", 11PowerVR SGX)             = 11
write(0, "PowerVR SGX", 11)             = 11
write(2, "\n", 1
)                       = 1
write(0, "\n", 1)                       = 1
openat(AT_FDCWD, "/dev/tty0", O_WRONLY) = 7
ioctl(7, VT_OPENQRY, 0x10c2e4)          = 0
close(7)                                = 0
gettimeofday({tv_sec=1577708483, tv_usec=427415}, NULL) = 0
write(0, "[1455485.795] ", 14)          = 14
write(2, "(--) using VT number 2\n\n", 24(--) using VT number 2

) = 24
write(0, "(--) using VT number 2\n\n", 24) = 24
getppid()                               = 3416
getpgid(3416)                           = 3416
setpgid(0, 3416)                        = 0
setsid()                                = 3418
openat(AT_FDCWD, "/dev/vc/2", O_RDWR|O_NONBLOCK) = -1 ENOENT (No such 
file or directory)
openat(AT_FDCWD, "/dev/tty2", O_RDWR|O_NONBLOCK) = 7
ioctl(7, VT_GETSTATE, 0xbede0a88)       = 0
ioctl(7, VT_ACTIVATE, 0x2)              = 0
ioctl(7, VT_WAITACTIVE, 0x2


But I have no idea at the moment why that blocks forever.
It doesn't seem to be in the pvr code (or at least it has no debug 
prints then).

Perhaps someone has an idea?

Regards,

Jeroen


Normal output is:


X.Org X Server 1.12.0
Release Date: 2012-03-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.35-30-generic-pae i686
Current Operating System: Linux ccgx 5.4.0 #1 Sun Dec 29 16:24:49 UTC 
2019 armv7l
Kernel command line:  root=ubi0:rootfs2 rootfstype=ubifs ubi.mtd=12 
vram=10M omapfb.vram=0:4M,1:3M,2:3M console=ttyO0,115200 
mtdparts=omap2-nand.0:128k(spl1),128k(spl2),128k(spl3),128k(spl4),1m(u-boot),256k(env1),256k(env2),1m(u-boot2),256k(bootparms),768k(splash),6m(kernel1),6m(kernel2),496m(ubisystem) 
5 console=ttyO0,115200
Build Date: 04 December 2012  07:46:23PM

Current version of pixman: 0.24.4
     Before reporting problems, check http://wiki.x.org
     to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
     (++) from command line, (!!) notice, (II) informational,
     (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/usr/local/XSGX/var/log/Xorg.0.log", Time: Mon Dec 30 
12:33:17 2019
(++) Using config file: "/media/sda1/usr/local/XSGX/etc/xorg.conf"
(==) ServerLayout "Server Layout"
(**) |-->Screen "Screen" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Video Device"
(==) No monitor specified for screen "Screen".
     Using a default monitor configuration.
(**) |-->Input Device "Keyboard"
(**) |-->Input Device "Main Touch Screen"
(==) Not automatically adding devices
(==) Not automatically enabling devices
(WW) The directory "/usr/local/XSGX/share/fonts/X11/TTF/" does not exist.
     Entry deleted from font path.
(WW) The directory "/usr/local/XSGX/share/fonts/X11/OTF/" does not exist.
     Entry deleted from font path.
(==) FontPath set to:
     /usr/local/XSGX/share/fonts/X11/misc/,
     /usr/local/XSGX/share/fonts/X11/Type1/,
     /usr/local/XSGX/share/fonts/X11/100dpi/,
     /usr/local/XSGX/share/fonts/X11/75dpi/
(==) ModulePath set to "/usr/local/XSGX/lib/xorg/modules"
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.0.0
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.0.0
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.0.0
(==) AIGLX enabled
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.13.0
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.0.0
(II) Loading /usr/local/XSGX/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 1.2.0
(II) Loading /usr/local/XSGX/lib/xorg/modules/drivers/pvr_drv.so
(II) Module PVR: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 109.218.8537
(II) Loading /usr/local/XSGX/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
     compiled for 1.12.0, module version = 2.6.0
(II) pvr: Driver for PowerVR chipsets: PowerVR SGX
(--) using VT number 2




More information about the openpvrsgx-devgroup mailing list